CompoundStructure.IsStructuralDeck Method

CompoundStructureIsStructuralDeck Method

Determines whether a specified layer is a structural deck.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsStructuralDeck(
	int layerIdx
)
Public Function IsStructuralDeck ( 
	layerIdx As Integer
) As Boolean
public:
bool IsStructuralDeck(
	int layerIdx
)
member IsStructuralDeck : 
        layerIdx : int -> bool 

Parameters

layerIdx  Int32
Index of a layer in the CompoundStructure.

Return Value

Boolean
True if specified layer is a structural deck, and false otherwise.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException The layer index is out of range.
See Also