ElementOnPhaseStatus Enumeration

ElementOnPhaseStatus Enumeration

The statuses that an element can have with respect to a given phase.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ElementOnPhaseStatus
Public Enumeration ElementOnPhaseStatus
public enum class ElementOnPhaseStatus
type ElementOnPhaseStatus
Members
Member nameValueDescription
Demolished3 Created before the given phase, to be demolished on the given phase
Existing2 Created in a previous phase, existing through the end of the given phase
Future6 Created after this phase
New4 Created on this phase (and not demolished)
None0 Phase status is undefined (e.g., for annotations)
Past1 Created and demolished before the given phase
Temporary5 Created and demolished during this phase
See Also