GeometryCreationUtilities.CreateRevolvedGeometry(Frame, IList<CurveLoop>, Double, Double, SolidOptions) Method

GeometryCreationUtilitiesCreateRevolvedGeometry(Frame, IListCurveLoop, Double, Double, SolidOptions) Method


Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static Solid CreateRevolvedGeometry(
	Frame coordinateFrame,
	IList<CurveLoop> profileLoops,
	double startAngle,
	double endAngle,
	SolidOptions solidOptions
)
Public Shared Function CreateRevolvedGeometry ( 
	coordinateFrame As Frame,
	profileLoops As IList(Of CurveLoop),
	startAngle As Double,
	endAngle As Double,
	solidOptions As SolidOptions
) As Solid
public:
static Solid^ CreateRevolvedGeometry(
	Frame^ coordinateFrame, 
	IList<CurveLoop^>^ profileLoops, 
	double startAngle, 
	double endAngle, 
	SolidOptions^ solidOptions
)
static member CreateRevolvedGeometry : 
        coordinateFrame : Frame * 
        profileLoops : IList<CurveLoop> * 
        startAngle : float * 
        endAngle : float * 
        solidOptions : SolidOptions -> Solid 

Parameters

coordinateFrame  Frame
 
profileLoops  IListCurveLoop
 
startAngle  Double
 
endAngle  Double
 
solidOptions  SolidOptions
 

Return Value

Solid
See Also