AnalyticalSupportPriority Enumeration

AnalyticalSupportPriority Enumeration

Defines how "highly" another Element is giving support for one Element.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum AnalyticalSupportPriority
Public Enumeration AnalyticalSupportPriority
public enum class AnalyticalSupportPriority
type AnalyticalSupportPriority
Members
Member nameValueDescription
FourthHigestPriority4 
HighestPriority1 
SecondHighestPriority2 
ThirdHighestPriority3 
UnknownPriority0 Priority has not been determined.
Remarks
For instance, a Column may be a higher priority for a Beam than another Beam. This is useful to find the best supports for a given Element.
See Also