SpecialType Enumeration

SpecialType Enumeration

An enumerated type listing special types that can appear in an ExportLayerTable. These types do not represent an independent category in Revit, but can be mapped to specific layers on export.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum SpecialType
Public Enumeration SpecialType
public enum class SpecialType
type SpecialType
Members
Member nameValueDescription
Default-1 The default value for most Revit categories and subcategories.
ExteriorWall2 The special type representing exterior walls.
FoundationWall3 The special type representing foundation walls.
InteriorWall1 The special type representing interior walls.
RetainingWall4 The special type representing retaining walls.
See Also