Curve.Length Property

CurveLength Property

The exact length of the curve.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public double Length { get; }
Public ReadOnly Property Length As Double
	Get
public:
property double Length {
	double get ();
}
member Length : float with get

Property Value

Double
Exceptions
ExceptionCondition
InvalidOperationException Thrown when the curve is unbound and not periodic.
Remarks
Computes the length of the curve using analytical or numeric integration. There is no performance hit for lines and arcs.
See Also