FabricationHostedInfo Class

FabricationHostedInfo Class

The fabrication hosted element information.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFabricationHostedInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FabricationHostedInfo : IDisposable
Public Class FabricationHostedInfo
	Implements IDisposable
public ref class FabricationHostedInfo : IDisposable
type FabricationHostedInfo = 
    class
        interface IDisposable
    end

The FabricationHostedInfo type exposes the following members.

Properties
 NameDescription
Public propertyHostId Returns the identifier of the host.
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisconnectFromHost Disconnects the part from the host.
Public methodDisposeReleases all resources used by the FabricationHostedInfo
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetBearerCenterline Gets the centerline of the bearer. The method is applicable only for bearer hanger.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodPlaceOnHost(ElementId, Connector, Double) Places the part on the specified host.
Public methodPlaceOnHost(ElementId, Connector, Double, Double) Places the part on the specified host.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
A fabrication part may have a host, the FabricationHostedInfo stores the host information for the fabrication part.
See Also