FamilyPointLocation Class

FamilyPointLocation Class

Data corresponding to the point locations in certain types of Family Symbols.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBFamilyPointLocation

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FamilyPointLocation : APIObject
Public Class FamilyPointLocation
	Inherits APIObject
public ref class FamilyPointLocation : public APIObject
type FamilyPointLocation = 
    class
        inherit APIObject
    end

The FamilyPointLocation type exposes the following members.

Properties
 NameDescription
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The name of the corresponding reference point in the Family document.
Top
Methods
 NameDescription
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLocation Gets the location of the point.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
Examples of FamilySymbol objects that contain placement references are Panels and Flexible Components.
See Also