Revit 2025.3 API
Boundary |
Returns curve loops that define geometry of the area boundary conditions.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public IList<CurveLoop> GetLoops()
Public Function GetLoops As IList(Of CurveLoop)
public: IList<CurveLoop^>^ GetLoops()
member GetLoops : unit -> IList<CurveLoop>
Return Value
IListCurveLoopThe curve loop collection.

Exception | Condition |
---|---|
InvalidObjectException | Thrown when BoundaryConditions is not a BoundaryConditionsType::Area type. |

Boundary conditions should be BoundaryConditionsType::Area type. Otherwise exception is thrown.
See Also