Element.GetTypeId Method

ElementGetTypeId Method

Returns the identifier of this element's type.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId GetTypeId()
Public Function GetTypeId As ElementId
public:
ElementId^ GetTypeId()
member GetTypeId : unit -> ElementId 

Return Value

ElementId
The id of the element's type, or invalid element id if the element cannot have type assigned.
Remarks
Some elements cannot have type assigned, in which case this method returns invalid element id.
See Also