WallUtils Class

WallUtils Class

General Wall utility methods
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBWallUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class WallUtils
Public NotInheritable Class WallUtils
public ref class WallUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type WallUtils = class end

The WallUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberAllowWallJoinAtEnd Allows the wall's end to join to other walls. If that end is near other walls it will become joined as a result.
Public methodStatic memberDisallowWallJoinAtEnd Sets the wall's end not to join to other walls.
Public methodStatic memberIsWallJoinAllowedAtEnd Identifies if the indicated end of the wall allows joins or not.
Top
See Also