BuiltInFailures.GlobalParameterFailures Class

BuiltInFailuresGlobalParameterFailures Class

Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBBuiltInFailuresGlobalParameterFailures

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class GlobalParameterFailures
Public NotInheritable Class GlobalParameterFailures
public ref class GlobalParameterFailures abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type GlobalParameterFailures = class end

The BuiltInFailuresGlobalParameterFailures type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberElementPropLinkCircularChain Linked properties in highlighted elements cause a circular chain of references.
Public propertyStatic memberElementPropLinkCircularChainError Linked properties in highlighted elements cause a circular chain of references.
Public propertyStatic memberGlobalParamFormulaCircularChain A formula in a global parameter causes a circular chain of references between highlighted elements.
Public propertyStatic memberGlobalParamFormulaCircularChainError A formula in a global parameter causes a circular chain of references between highlighted elements.
Public propertyStatic memberGlobalParamInvalidElemParamValue Invalid value of parameter %1!s! in highlighted element.
Public propertyStatic memberInvalidElementPropToGlobalParamLink The following parameters of the highlighted element can no longer be linked to global parameters: %1!s!.
Top
See Also