Revit 2025.3 API
DocumentIs |
Indicates whether there are any background calculations in progress for this document.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool IsBackgroundCalculationInProgress()
Public Function IsBackgroundCalculationInProgress As Boolean
public: bool IsBackgroundCalculationInProgress()
member IsBackgroundCalculationInProgress : unit -> bool
Return Value
BooleanReturns true if the document has any data calculation in progress and false otherwise.

When a document has background export in progress,
users cannot perform document close.
For any other background calculation in progress, users cannot perform the following operations:
- Save/Close the document.
- Export/Print the document.
- Synchronize to central, in worksharing environment.
- Create a steel element.
- Copy/Mirror/Rotate a steel element.
- Edit the sketch of plate element.
- Edit a custom connection.
See Also