ExternalFileUtils Class

ExternalFileUtils Class

A utility class containing functions related to external file references.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBExternalFileUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class ExternalFileUtils
Public NotInheritable Class ExternalFileUtils
public ref class ExternalFileUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ExternalFileUtils = class end

The ExternalFileUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberGetAllExternalFileReferences Gets the ids of all elements which are external file references.
Public methodStatic memberGetExternalFileReference Gets the external file referencing data for the given element.
Public methodStatic memberGetFileBasedTempFolder Gets a temp folder based on the given file name
Public methodStatic memberIsExternalFileReference Determines whether the given element represents an external file.
Top
Remarks
Elements which are external file references refer to files outside of the base .rvt file. Examples include Revit links, CAD links, the element which stores the location of the keynote file, and rendering decals.
See Also