Revit 2025.3 API
Built |
Failures about Curves and Curve-Driven Elements.

SystemObject
Autodesk.Revit.DBBuiltInFailuresCurveFailures
Autodesk.Revit.DBBuiltInFailuresCurveFailures
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The BuiltInFailuresCurveFailures type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | CannotFindAreaScheme | Can't find new Area Scheme for Area Boundary. |
![]() ![]() | CantKeepJoinTangent | Can't keep curve join tangent. |
![]() ![]() | CurveNotEditable | Lines created by massing or picking 3d path are not editable. |
![]() ![]() | CurveNotEditableWarn | Lines created by massing or picking 3d path are not editable. |
![]() ![]() | InvalidCurveForElement | End positions are invalid. |
![]() ![]() | LineTooShortError | Line is too short. |
![]() ![]() | LineTooShortWarning | Line is too short. |
![]() ![]() | PeriodicCurveBadParams | End positions are invalid. |
![]() ![]() | SelfIntersectingSpline | Self intersecting splines are not allowed in sketches. |
![]() ![]() | TooShort | Line is too short. |
![]() ![]() | TopLevelBelowBottomLevel | For curveElem support multiple levels, top level belows curve bottom level. |
See Also