CopyPasteOptions Class

CopyPasteOptions Class

Settings to control the behavior of a copy-paste operation.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBCopyPasteOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class CopyPasteOptions : IDisposable
Public Class CopyPasteOptions
	Implements IDisposable
public ref class CopyPasteOptions : IDisposable
type CopyPasteOptions = 
    class
        interface IDisposable
    end

The CopyPasteOptions type exposes the following members.

Constructors
 NameDescription
Public methodCopyPasteOptions Creates a new instance of a CopyPasteOptions object.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the CopyPasteOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetDuplicateTypeNamesHandler Returns current duplicate type names handler or if none is set.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetDuplicateTypeNamesHandler Sets a custom duplicate type names handler. If this value is not set, the default handler is used. By default, Revit displays a modal dialog with options to either copy new types only, or cancel the operation.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also