Revit 2025.3 API
Independent |
The tag orientation of the tag's head, such as horizontal or vertical.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public TagOrientation TagOrientation { get; set; }
Public Property TagOrientation As TagOrientation Get Set
public: property TagOrientation TagOrientation { TagOrientation get (); void set (TagOrientation value); }
member TagOrientation : TagOrientation with get, set
Property Value
TagOrientation
Exception | Condition |
---|---|
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |

TagOrientation for the supported orientations.
Tags from types that have rotate with component turned on ignore the TagOrientation property.
Tags that are not in tag mode ignores the TagOrientation property.
See Also