FamilySizeTableErrorType Enumeration

FamilySizeTableErrorType Enumeration

The set of errors that can be returned when importing a FamilySizeTable from a CSV file.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum FamilySizeTableErrorType
Public Enumeration FamilySizeTableErrorType
public enum class FamilySizeTableErrorType
type FamilySizeTableErrorType
Members
Member nameValueDescription
CannotOpenFile1 Failed to open the FamilySizeTable CSV file.
CannotParseColumnHeader4 Failed to parse the column header of the FamilySizeTable CSV file.
CannotReadFile2 Failed to read the FamilySizeTable CSV file.
FileNotFound0 The FamilySize Table CSV file was not found.
IncorrectNumberOfColumns5 The number of columns in the header row of the FamilySizeTable CSV file is different than the number of columns of data.
InvalidHeaderSeparator3 The CSV file header separator is not invalid. Valid header separators are comma(,), semicolon(;), colon(:), and pipe (|).
Undefined-1 Undefined error.
See Also