Parameter.Definition Property

ParameterDefinition Property

Returns the Definition object that describes the data type, name and other details of the parameter.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public Definition Definition { get; }
Public ReadOnly Property Definition As Definition
	Get
public:
property Definition^ Definition {
	Definition^ get ();
}
member Definition : Definition with get

Property Value

Definition
Remarks
This will always be an InternalDefinition object. If you want the Guid for a shared parameter, use GUID.
See Also