View.Print(Boolean) Method

ViewPrint(Boolean) Method

Print this view with the default view template, and either the view's document's print setting or the print setting of the current active document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public void Print(
	bool useCurrentPrintSettings
)
Public Sub Print ( 
	useCurrentPrintSettings As Boolean
)
public:
void Print(
	bool useCurrentPrintSettings
)
member Print : 
        useCurrentPrintSettings : bool -> unit 

Parameters

useCurrentPrintSettings  Boolean
If true, print the view with the print setting of the current active document; otherwise with the view's document's print setting.
Exceptions
ExceptionCondition
InvalidOperationExceptionThrown when the view cannot be printed.
See Also