RebarFreeFormValidationResult Enumeration

RebarFreeFormValidationResult Enumeration

Errors for the Free Form Rebar

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum RebarFreeFormValidationResult
Public Enumeration RebarFreeFormValidationResult
public enum class RebarFreeFormValidationResult
type RebarFreeFormValidationResult
Members
Member nameValueDescription
InvalidLoop4 Curves doesn't form a valid curve loop.
NullCurve2 One or more of the input curves was null.
RebarCantBeBent5 A rebar constructed from curves can't be bent according to the bending radius.
Success0 Operation was done with success.
UnboundCurve3 One or more of the input curves was unbounded.
Undefined1 An unexpected error occured.
See Also