Revit 2025.3 API
GBXMLExport |
The energy model type from which gbXML will be exported.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ExportEnergyModelType ExportEnergyModelType { get; set; }
Public Property ExportEnergyModelType As ExportEnergyModelType Get Set
public: property ExportEnergyModelType ExportEnergyModelType { ExportEnergyModelType get (); void set (ExportEnergyModelType value); }
member ExportEnergyModelType : ExportEnergyModelType with get, set
Property Value
ExportEnergyModelType
Exception | Condition |
---|---|
ArgumentOutOfRangeException | When setting this property: A value passed for an enumeration argument is not a member of that enumeration |

Default value is SpatialElement.
See Also