SpatialElementDomainData Class

SpatialElementDomainData Class

A base class for specific domain requirements for a spatial element.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBSpatialElementDomainData
    Autodesk.Revit.DB.ElectricalElectricalLoadAreaData

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class SpatialElementDomainData : IDisposable
Public Class SpatialElementDomainData
	Implements IDisposable
public ref class SpatialElementDomainData : IDisposable
type SpatialElementDomainData = 
    class
        interface IDisposable
    end

The SpatialElementDomainData type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the SpatialElementDomainData
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also