ViewDisplayBackgroundType Enumeration

ViewDisplayBackgroundType Enumeration

A collection of settings defining the type of the view background

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ViewDisplayBackgroundType
Public Enumeration ViewDisplayBackgroundType
public enum class ViewDisplayBackgroundType
type ViewDisplayBackgroundType
Members
Member nameValueDescription
Gradient257 Three-color simulated sky-horizon-ground combination. The sky is drawn in gradually changing color from the top (the "sky" color) to the bottom (the "horizon" color). The ground is either drawn in the single (the "ground") color, if the sky is visible, or in a gradient from the top (the "horizon") color to the bottom (the "ground") color.
Image258 User-specified image is drawn in the background either stretched vertically/horizontally/in both directions, or as is (pixel-to-pixel).
None256 No background defined - the color from Options is used to fill it.
SunAndClouds512 Best approximation to the colors of the sky and the visible sun disk. The position of the visible sun disk is calculated based on the "sun and shadow settings" (see 'ViewBackgroundLighting' object).
See Also