FacetingUtils Class

FacetingUtils Class

This class is used to convertTrianglesToQuads a triangulated structure into a structure in which some of the triangles have been consolidated into quadrilaterals.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFacetingUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class FacetingUtils
Public NotInheritable Class FacetingUtils
public ref class FacetingUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type FacetingUtils = class end

The FacetingUtils type exposes the following members.

Methods
 NameDescription
Public methodStatic memberConvertTrianglesToQuads Replaces pairs of adjacent, coplanar triangles by quadrilaterals.
Top
See Also