DocumentPreviewSettings Class

DocumentPreviewSettings Class

Contains the settings related to the saving of preview images for a given document.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBDocumentPreviewSettings

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class DocumentPreviewSettings : IDisposable
Public Class DocumentPreviewSettings
	Implements IDisposable
public ref class DocumentPreviewSettings : IDisposable
type DocumentPreviewSettings = 
    class
        interface IDisposable
    end

The DocumentPreviewSettings type exposes the following members.

Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyIsViewUpdateForced Identifies if Revit will update the preview view if necessary.
Public propertyPreviewViewId The view id that will be used to generate the preview.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the DocumentPreviewSettings
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodForceViewUpdate Sets Revit to update the preview view if necessary.
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIsViewIdValidForPreview Identifies if the view id is valid as a preview view id.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also