Revit 2025.3 API
Beam |
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static BeamSystem Create( Document document, IList<Curve> profile, SketchPlane sketchPlane, XYZ direction, bool is3d )
Public Shared Function Create ( document As Document, profile As IList(Of Curve), sketchPlane As SketchPlane, direction As XYZ, is3d As Boolean ) As BeamSystem
public: static BeamSystem^ Create( Document^ document, IList<Curve^>^ profile, SketchPlane^ sketchPlane, XYZ^ direction, bool is3d )
static member Create : document : Document * profile : IList<Curve> * sketchPlane : SketchPlane * direction : XYZ * is3d : bool -> BeamSystem
Parameters
- document Document
- profile IListCurve
- sketchPlane SketchPlane
- direction XYZ
- is3d Boolean
Return Value
BeamSystemSee Also