VertexIndexPairArrayIterator Class

VertexIndexPairArrayIterator Class

An iterator to an array of VertexIndex pairs.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBVertexIndexPairArrayIterator

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public abstract class VertexIndexPairArrayIterator : APIObject, 
	IEnumerator
Public MustInherit Class VertexIndexPairArrayIterator
	Inherits APIObject
	Implements IEnumerator
public ref class VertexIndexPairArrayIterator abstract : public APIObject, 
	IEnumerator
[<AbstractClassAttribute>]
type VertexIndexPairArrayIterator = 
    class
        inherit APIObject
        interface IEnumerator
    end

The VertexIndexPairArrayIterator type exposes the following members.

Constructors
 NameDescription
Public methodVertexIndexPairArrayIteratorFor Internal Use Only.
Top
Properties
 NameDescription
Public propertyCurrentRetrieves the item that is the current focus of the iterator.
Top
Methods
 NameDescription
Public methodMoveNextMove the iterator one item forward.
Public methodResetBring the iterator back to the start of the array.
Top
See Also