Line Class

Line Class

A line in space.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBCurve
        Autodesk.Revit.DBLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Line : Curve
Public Class Line
	Inherits Curve
public ref class Line : public Curve
type Line = 
    class
        inherit Curve
    end

The Line type exposes the following members.

Properties
 NameDescription
Public propertyApproximateLengthThe approximate length of the curve.
(Inherited from Curve)
Public propertyDirectionReturns the direction of the line.
Public propertyGraphicsStyleIdThe ElementId of the GeometryObject's GraphicsStyle
(Inherited from GeometryObject)
Public propertyIdA unique integer identifying the GeometryObject in its associated non view-specific GeometryElement.
(Inherited from GeometryObject)
Public propertyIsBoundDescribes whether the parameter of the curve is restricted to a particular interval.
(Inherited from Curve)
Public propertyIsClosedDescribes whether the curve is closed.
(Inherited from Curve)
Public propertyIsCyclicThe boolean value that indicates whether this curve is cyclic.
(Inherited from Curve)
Public propertyIsElementGeometryIndicates whether this geometry is obtained directly from an Element.
(Inherited from GeometryObject)
Public propertyIsReadOnlyIdentifies if the object is read-only or modifiable.
(Inherited from APIObject)
Public propertyLengthThe exact length of the curve.
(Inherited from Curve)
Public propertyOriginReturns the origin of the line.
Public propertyPeriodThe period of this curve.
(Inherited from Curve)
Public propertyReferenceReturns a stable reference to the curve.
(Inherited from Curve)
Public propertyVisibilityThe visibility.
(Inherited from GeometryObject)
Top
Methods
 NameDescription
Public methodCloneReturns a copy of this curve.
(Inherited from Curve)
Public methodComputeClosestPoints
(Inherited from Curve)
Public methodComputeDerivatives Returns the vectors describing the curve at the specified parameter.
(Inherited from Curve)
Public methodComputeNormalizedParameterComputes the normalized curve parameter from the raw parameter.
(Inherited from Curve)
Public methodComputeRawParameterComputes the raw parameter from the normalized parameter.
(Inherited from Curve)
Public methodStatic memberCreateBound Creates a new instance of a bound linear curve.
Public methodCreateOffset Creates a new curve that is an offset of the existing curve.
(Inherited from Curve)
Public methodCreateReversed Creates a new curve with the opposite orientation of the existing curve.
(Inherited from Curve)
Public methodCreateTransformed Crates a new instance of a curve as a transformation of this curve.
(Inherited from Curve)
Public methodStatic memberCreateUnbound Creates a new instance of an unbound linear curve.
Public methodDisposeCauses the object to release immediately any resources it may be utilizing.
(Inherited from APIObject)
Public methodDistanceReturns the shortest distance from the specified point to this curve.
(Inherited from Curve)
Public methodEquals Determines whether the specified Object is equal to the current Object.
(Inherited from GeometryObject)
Public methodEvaluate Evaluates and returns the point that matches a parameter along the curve.
(Inherited from Curve)
Public methodGetEndParameter Returns the raw parameter value at the start or end of this curve.
(Inherited from Curve)
Public methodGetEndPoint Returns the 3D point at the start or end of this curve.
(Inherited from Curve)
Public methodGetEndPointReferenceReturns a stable reference to the start point or the end point of the curve.
(Inherited from Curve)
Public methodGetHashCode Gets the integer value of the geometry object as hash code
(Inherited from GeometryObject)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodIntersect(Curve)Calculates the intersection of this curve with the specified curve.
(Inherited from Curve)
Public methodIntersect(Curve, IntersectionResultArray)Calculates the intersection of this curve with the specified curve and returns the intersection results.
(Inherited from Curve)
Public methodIsInside(Double)Indicates whether the specified parameter value is within this curve's bounds.
(Inherited from Curve)
Public methodIsInside(Double, Int32)Indicates whether the specified parameter value is within this curve's bounds and outputs the end index.
(Inherited from Curve)
Public methodMakeBoundChanges the bounds of this curve to the specified values.
(Inherited from Curve)
Public methodMakeUnboundMakes this curve unbound.
(Inherited from Curve)
Public methodProjectProjects the specified point on this curve.
(Inherited from Curve)
Public methodSetGraphicsStyleIdSets the graphics style id for this curve.
(Inherited from Curve)
Public methodTessellateValid only if the curve is bound. Returns a polyline approximation to the curve.
(Inherited from Curve)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also