Line Class

Line Class

A line in space.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBAPIObject
    Autodesk.Revit.DBGeometryObject
      Autodesk.Revit.DBCurve
        Autodesk.Revit.DBLine

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class Line : Curve
Public Class Line
	Inherits Curve
public ref class Line : public Curve
type Line = 
    class
        inherit Curve
    end

The Line type exposes the following members.

Properties
 NameDescription
Public propertyDirectionReturns the direction of the line.
Public propertyOriginReturns the origin of the line.
Top
Methods
 NameDescription
Public methodStatic memberCreateBound Creates a new instance of a bound linear curve.
Public methodStatic memberCreateUnbound Creates a new instance of an unbound linear curve.
Top
See Also