Revit 2025.3 API
Element |
Constructs a new instance of a filter to match only curve driven elements, with the option to match all elements which are not curve driven elements.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementIsCurveDrivenFilter( bool inverted )
Public Sub New ( inverted As Boolean )
public: ElementIsCurveDrivenFilter( bool inverted )
new : inverted : bool -> ElementIsCurveDrivenFilter
Parameters
- inverted Boolean
- True if the filter should match all elements which are not curve driven elements.

The term "curve driven" indicates that the element's Location property is a LocationCurve.
Example elements found by this filter include walls, beams, and curve elements.
See Also