RebarHookOrientation Enumeration

RebarHookOrientation Enumeration

Orientation of a rebar hook relative to the path of the Rebar Shape.

Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum RebarHookOrientation
Public Enumeration RebarHookOrientation
public enum class RebarHookOrientation
type RebarHookOrientation
Members
Member nameValueDescription
Left1 Hook towards the left of a segment-based shape (RebarShapeDefinitionBySegments), or to the interior of an arc-based shape (RebarShapeDefinitionByArc).
Right-1 Hook towards the right of a segment-based shape (RebarShapeDefinitionBySegments), or to the exterior of an arc-based shape (RebarShapeDefinitionByArc).
See Also