Revit 2025.3 API
DocumentGet |
Gets ForgeDM hub id where the model locates. It is cached in session.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public string GetHubId()
Public Function GetHubId As String
public: String^ GetHubId()
member GetHubId : unit -> string
Return Value
String
Exception | Condition |
---|---|
RevitServerUnauthorizedException | Thrown when cannot get data from ForgeDM for Revit cloud model. |

It is empty for non-cloud model;
It is cached in Revit model opened session after getting it;
See Also