Revit 2025.3 API
Background |
Represents the rendering background settings.

SystemObject
Autodesk.Revit.DBBackgroundSettings
Autodesk.Revit.DBColorBackgroundSettings
Autodesk.Revit.DBGradientBackgroundSettings
Autodesk.Revit.DBImageBackgroundSettings
Autodesk.Revit.DBSkyBackgroundSettings
Autodesk.Revit.DBBackgroundSettings
Autodesk.Revit.DBColorBackgroundSettings
Autodesk.Revit.DBGradientBackgroundSettings
Autodesk.Revit.DBImageBackgroundSettings
Autodesk.Revit.DBSkyBackgroundSettings
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The BackgroundSettings type exposes the following members.

Name | Description | |
---|---|---|
![]() | IsValidObject | Specifies whether the .NET object represents a valid Revit entity. |

Name | Description | |
---|---|---|
![]() | Dispose | Releases all resources used by the BackgroundSettings |
See Also