Revit 2025.3 API
FaceIs |
Indicates whether the underlying surface is periodic in the specified parametric direction.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool this[ int paramIdx ] { get; }
Public ReadOnly Property IsCyclic ( paramIdx As Integer ) As Boolean Get
public: property bool IsCyclic[int paramIdx] { bool get (int paramIdx); }
member IsCyclic : bool with get
Parameters
- paramIdx Int32
- Use 0 for U coordinates and 1 for V coordinates.
Return Value
BooleanTrue if the underlying surface is cyclic in the specified coordinate space; otherwise, false.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | Thrown when an incorrect coordinate dimension is supplied. |
See Also