FilterStringEndsWith Class

FilterStringEndsWith Class

Tests whether string values from the document end with a certain string.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFilterStringRuleEvaluator
    Autodesk.Revit.DBFilterStringEndsWith

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FilterStringEndsWith : FilterStringRuleEvaluator
Public Class FilterStringEndsWith
	Inherits FilterStringRuleEvaluator
public ref class FilterStringEndsWith : public FilterStringRuleEvaluator
type FilterStringEndsWith = 
    class
        inherit FilterStringRuleEvaluator
    end

The FilterStringEndsWith type exposes the following members.

Constructors
 NameDescription
Public methodFilterStringEndsWith Constructs an instance of FilterStringEndsWith.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
(Inherited from FilterStringRuleEvaluator)
Top
Methods
 NameDescription
Public methodDispose
(Inherited from FilterStringRuleEvaluator)
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodEvaluate Derived classes override this method to implement the test that determines whether the two given string values satisfy the desired condition or not.
(Inherited from FilterStringRuleEvaluator)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
All string comparisons in this class are performed in the case-insensitive manner.
See Also