ViewportPositioning Enumeration

ViewportPositioning Enumeration

An enumerated type listing of viewport positioning options on the sheet when swapped to another view.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum ViewportPositioning
Public Enumeration ViewportPositioning
public enum class ViewportPositioning
type ViewportPositioning
Members
Member nameValueDescription
ViewOrigin1 When swapping to another view, the viewport location will be based on the view origin.
ViewportCenter0 When swapping to another view, the center of the viewport will be maintained.
See Also