FolderItemInfo Class

FolderItemInfo Class

Contains data for each folder item in the organization settings of the project browser including folder parameter Id and folder name.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBFolderItemInfo

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class FolderItemInfo : IDisposable
Public Class FolderItemInfo
	Implements IDisposable
public ref class FolderItemInfo : IDisposable
type FolderItemInfo = 
    class
        interface IDisposable
    end

The FolderItemInfo type exposes the following members.

Properties
 NameDescription
Public propertyElementId The folder parameter Id
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Public propertyName The folder name
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the FolderItemInfo
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
Remarks
FolderItemInfo is the return value of BrowserOrganization.GetFolderItems().
See Also