Revit 2025.3 API
Fabrication |
Set the length of the rod's top extension into structure. The rod must be attached to structure.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool SetRodStructureExtension( int rodIndex, double extension )
Public Function SetRodStructureExtension ( rodIndex As Integer, extension As Double ) As Boolean
public: bool SetRodStructureExtension( int rodIndex, double extension )
member SetRodStructureExtension : rodIndex : int * extension : float -> bool
Parameters
- rodIndex Int32
- The rod index.
- extension Double
- Distance the rod will extend into the structure.
Return Value
BooleanReturns true if it was successful otherwise false.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count. |
InvalidOperationException | The rods do not attached to any structue. |
See Also