Revit 2025.3 API
TransactionGet |
Returns the current failure handling options.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public FailureHandlingOptions GetFailureHandlingOptions()
Public Function GetFailureHandlingOptions As FailureHandlingOptions
public: FailureHandlingOptions^ GetFailureHandlingOptions()
member GetFailureHandlingOptions : unit -> FailureHandlingOptions
Return Value
FailureHandlingOptionsAn instance of FailureHandlingOptions

The returned instance is a copy of the options.
If changes are made to the options, the new version can be set back to
the transaction by calling the SetFailureHandlingOptions(FailureHandlingOptions) method.
See Also