ElementIs |
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
public bool IsTransient { get; }
Public ReadOnly Property IsTransient As Boolean Get
public: property bool IsTransient { bool get (); }
member IsTransient : bool with get
Property Value
Boolean
Transient elements are usually created for short term use. This type of element can be created via Document.MakeTransientElements().
Transient and Permanent elements are not allowed to reference each other. A transient element can only refer to other transient elements in the same document.
Transient elements also cannot be selected or scheduled, and will not be saved when the document is saved, and will be discarded when the document is closed.
Modifying a transient element does not require a transaction, because such elements are not part of the model. As an effect of this, however, creation and modification of transients cannot be undone.
Because transient elements are technically not part of the model, they will not be found when using standard element filters, or in any collection of elements Revit returns, such as elements reported in dynamic updaters, etc.