ModelPathUtils Class

ModelPathUtils Class

Utility functions using ModelPaths
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBModelPathUtils

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public static class ModelPathUtils
Public NotInheritable Class ModelPathUtils
public ref class ModelPathUtils abstract sealed
[<AbstractClassAttribute>]
[<SealedAttribute>]
type ModelPathUtils = class end

The ModelPathUtils type exposes the following members.

Properties
 NameDescription
Public propertyStatic memberCloudRegionEMEA The name of cloud region EMEA.
Public propertyStatic memberCloudRegionUS The name of cloud region US.
Top
Methods
 NameDescription
Public methodStatic memberConvertCloudGUIDsToCloudPath Converts a pair of cloud project and model GUIDs to a valid cloud path.
Public methodStatic memberConvertModelPathToUserVisiblePath Gets a string version of the path of a given ModelPath.
Public methodStatic memberConvertUserVisiblePathToModelPath Converts a user-visible path (string) to a ModelPath.
Public methodStatic memberIsValidUserVisibleFullServerPath Determines whether the given string represents a valid server path.
Top
See Also