CompoundStructure.GetMaterialId Method

CompoundStructureGetMaterialId Method

Retrieves the material element id of a specified layer.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public ElementId GetMaterialId(
	int layerIdx
)
Public Function GetMaterialId ( 
	layerIdx As Integer
) As ElementId
public:
ElementId^ GetMaterialId(
	int layerIdx
)
member GetMaterialId : 
        layerIdx : int -> ElementId 

Parameters

layerIdx  Int32
Index of a layer in the CompoundStructure.

Return Value

ElementId
The material element id.
Exceptions
ExceptionCondition
ArgumentOutOfRangeException The layer index is out of range.
See Also