TransactWithCentralOptions Class

TransactWithCentralOptions Class

Options to customize Revit behavior when accessing the central model.
Inheritance Hierarchy
SystemObject
  Autodesk.Revit.DBTransactWithCentralOptions

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public class TransactWithCentralOptions : IDisposable
Public Class TransactWithCentralOptions
	Implements IDisposable
public ref class TransactWithCentralOptions : IDisposable
type TransactWithCentralOptions = 
    class
        interface IDisposable
    end

The TransactWithCentralOptions type exposes the following members.

Constructors
 NameDescription
Public methodTransactWithCentralOptions Constructs a new TransactWithCentralOptions.
Top
Properties
 NameDescription
Public propertyIsValidObject Specifies whether the .NET object represents a valid Revit entity.
Top
Methods
 NameDescription
Public methodDisposeReleases all resources used by the TransactWithCentralOptions
Public methodEqualsDetermines whether the specified object is equal to the current object.
(Inherited from Object)
Public methodGetHashCodeServes as the default hash function.
(Inherited from Object)
Public methodGetLockCallback Gets the callback object that changes Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public methodGetTypeGets the Type of the current instance.
(Inherited from Object)
Public methodSetLockCallback Sets or resets a callback object that would allow an external application to change Revit's default behavior of endlessly waiting and repeatedly trying to lock a central model.
Public methodToStringReturns a string that represents the current object.
(Inherited from Object)
Top
See Also