Revit 2025.3 API
Rebar |
Returns the RebarCoverType for the face specified by targetIndex. Returns null if no RebarHostData is present for target element.
Namespace: Autodesk.Revit.DB.Structure
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public RebarCoverType GetTargetCoverType( int targetIndex )
Public Function GetTargetCoverType ( targetIndex As Integer ) As RebarCoverType
public: RebarCoverType^ GetTargetCoverType( int targetIndex )
member GetTargetCoverType : targetIndex : int -> RebarCoverType
Parameters
- targetIndex Int32
- The index of the target. Should be between 0 and NumberOfTargets().
Return Value
RebarCoverType
Exception | Condition |
---|---|
ArgumentException | targetIndex is out of range. |
InvalidOperationException | RebarConstraint is no longer valid. -or- The RebarConstraint is not of RebarConstraintType 'FixedDistanceToHostFace' or 'ToCover'. |
See Also