Revit 2025.3 API
Sub |
Determines whether the sub-transaction has been started yet.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public bool HasStarted()
Public Function HasStarted As Boolean
public: bool HasStarted()
member HasStarted : unit -> bool
Return Value
BooleanTrue if the sub-transaction has already started, False otherwise.

A sub-transaction is considered being started after the Start
method was called and until the sub-transaction is either committed or rolled back.
See Also