HorizontalTextAlignment Enumeration

HorizontalTextAlignment Enumeration

Supported types of horizontal alignment of a text element and text justification within the text containing box.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public enum HorizontalTextAlignment
Public Enumeration HorizontalTextAlignment
public enum class HorizontalTextAlignment
type HorizontalTextAlignment
Members
Member nameValueDescription
Center2 Text is Center justified inside the containing text box, and the center side of the text box remains in place as the width changes.
Left0 Text is Left justified inside the containing text box, and the left side of the text box remains in place as the width changes.
Right1 Text is Right justified inside the containing text box, and the right side of the text box remains in place as the width changes.
See Also