Element.UniqueId Property

ElementUniqueId Property

A stable unique identifier for an element within the document.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public string UniqueId { get; }
Public ReadOnly Property UniqueId As String
	Get
public:
property String^ UniqueId {
	String^ get ();
}
member UniqueId : string with get

Property Value

String
Remarks
The UniqueId can be used to store an identifier in an external database and to retrieve the same element in the future if it still exists. This id can be passed to the Document's Element property to retrieve the element. The UniqueId is stable across upgrades and workset operations such as Save To Central, while the ElementId property may change.
See Also