Revit 2025.3 API
External |
This class gives access to external services.
Use it to register external services with Revit and execute them.
Only the application that registers a service is allowed to execute it.

SystemObject
Autodesk.Revit.DB.ExternalServiceExternalServiceRegistry
Autodesk.Revit.DB.ExternalServiceExternalServiceRegistry
Namespace: Autodesk.Revit.DB.ExternalService
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
The ExternalServiceRegistry type exposes the following members.

Name | Description | |
---|---|---|
![]() ![]() | ExecuteService(Guid, IExternalData) | Execute a service independently of any document. |
![]() ![]() | ExecuteService(Guid, Document, IExternalData) | Execute the service for the given document. |
![]() ![]() | ExecuteService(Guid, Guid, IExternalData) | Execute the service by the given server. |
![]() ![]() | GetService | Returns an instance of an object that represents the external service with the given Id. |
![]() ![]() | GetServices | Returns a collection of all external services currently registered in Revit. |
![]() ![]() | RegisterService(ISingleServerService, ExternalServiceOptions) | A method to register a single-server service. |
![]() ![]() | RegisterService(IMultiServerService, ExternalServiceOptions, ExecutionPolicy) | A method to register a multi-server service. |
![]() ![]() | RegisterService(ISingleServerService, Guid, ExternalServiceOptions) | A method to register a mandatory, single-server service. |
See Also