XYZ(Double, Double, Double) Constructor

XYZ(Double, Double, Double) Constructor

Creates an XYZ with the supplied coordinates.

Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ(
	double x,
	double y,
	double z
)
Public Sub New ( 
	x As Double,
	y As Double,
	z As Double
)
public:
XYZ(
	double x, 
	double y, 
	double z
)
new : 
        x : float * 
        y : float * 
        z : float -> XYZ

Parameters

x  Double
The first coordinate.
y  Double
The second coordinate.
z  Double
The third coordinate.
Exceptions
ExceptionCondition
ArgumentException Thrown when setting an infinite number to the X, Y or Z property.
See Also