Revit 2025.3 API
Fabrication |
Gets the position of the rod end.
Namespace: Autodesk.Revit.DB
Assembly: RevitAPI (in RevitAPI.dll) Version: 25.3.0.0 (25.3.0.0)
Syntax
public XYZ GetRodEndPosition( int rodIndex )
Public Function GetRodEndPosition ( rodIndex As Integer ) As XYZ
public: XYZ^ GetRodEndPosition( int rodIndex )
member GetRodEndPosition : rodIndex : int -> XYZ
Parameters
- rodIndex Int32
- The index of the rod.
Return Value
XYZThe position of the rod end.

Exception | Condition |
---|---|
ArgumentOutOfRangeException | the index rodIndex is should be in range of rod count. |
See Also